昨天随手一点brew upadte & brew upgrade后phpunit出现了各种F,细查下来原来是 php 5.5.17 的一个bug fix 引起的。为了暂时正常使用phpunit,只能回退php的版本。

版本切换方式

通过brew安装的php可以通过brew linkbrew unlink来切换不同版本。

例如

brew list
brew unlink php56
brew link php55

大版本可以用brew list来查,如果是小版本的话只能去/usr/local/Cellar/php55看了。这个时候使用php-version可以更方便一点。

安装php-version

php-version是一个帮助管理从brew安装的php版本切换的工具。

安装非常简单

brew install php-version

然后执行

source $(brew --prefix php-version)/php-version.sh && php-version 5

使用php-version

直接执行

php-version

就可以看到现有的版本,比如我自己的

$ php-version
  5.5.15
* 5.5.16
  5.5.17

然后使用以下命令切换即可

php-version 5.5.15

再看php的版本,已经切换好了。